【PAT甲级】1004 Counting Leaves (树的遍历,求每层叶子结点数)

题目链接:1004 Counting Leaves

1 题目描述

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification

Each input file contains one test case. Each case starts with a line containing $0 < N < 100$, the number of nodes in a tree, and $M (< N)$, the number of non-leaf nodes. Then $M$ lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.
The input ends with $N$ being 0. That case must NOT be processed.

Output Specification

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input

2 1
01 1 02

Sample Output

0 1

2 解题思路

  • 给你一个家谱,找到没有孩子的人。即需要统计树中的叶子结点数量,可用 $dfs$ 进行树的遍历操作。
  • 采用vector进行存储树的结构,遍历vector,当vector[i].size()==0时,表明该结点没有叶子结点,所以它本身即为叶子结点。

3 题解

#include <iostream>
#include <cstdio>
#include <vector>
using namespace std;

const int maxn = 105;
vector<int> v[maxn];
int arr[maxn];
int maxDepth = -1;

void dfs(int index, int depth){
    //统计index节点是否为叶子结点
    if(v[index].size() == 0){
        //叶子结点数量加1
        arr[depth]++;
        //找出该树的最大层次
        maxDepth = max(maxDepth, depth);
        return;
    }
    //如果index结点不是叶子结点,则遍历index的叶子结点
    for(int i = 0;i < v[index].size();i++){
        dfs(v[index][i], depth + 1);
    }
}

int main(){
    #ifdef ONLINE_JUDGE
    #else
    freopen("input.txt", "r", stdin);
    #endif // ONLINE_JUDGE

    ios::sync_with_stdio(false);
    cin.tie();cout.tie();

    int n, m;
    while(cin >> n >> m){
        for(int i = 0;i < m;i++){
            int node, k;
            cin >> node >> k;
            for(int j = 0;j < k;j++){
                int temp;
                cin >> temp;
                v[node].push_back(temp);
            }
        }
    }

    dfs(1, 0);

    cout << arr[0];
    for(int i = 1;i <= maxDepth;i++){
        cout << " " << arr[i];
    }
    return 0;
}