【PAT甲级】1007 Maximum Subsequence Sum(最大连续子列和,dp)

题目链接:1007 Maximum Subsequence Sum

1 题目描述

Given a sequence of $K$ integers {N​1​​, N​2, …, N​K​​}. A continuous subsequence is defined to be { N​i​​, N{​i+1}​​, …, Nj​​} where $1 ≤ i ≤ j ≤ K$. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { $-2, 11, -4, 13, -5, -2$ }, its maximum subsequence is { $11, -4, 13$ } with the largest sum being $20$.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer $K (≤10000)$. The second line contains $K$ numbers, separated by a space.

Output Specification

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices $i$ and $j$ (as shown by the sample case). If all the $K$ numbers are negative, then its maximum sum is defined to be $0$, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output

10 1 4

2 解题思路

  • 题目大意:求最大连续子列和,输出最大的和以及这个子序列的开始值与结束值。如果所有的数都小于 $0$ , 则和为 $0$ ,输出首尾元素。

  • 注意题中有一个坑:

    If all the $K$ numbers are negative, then its maximum sum is defined to be $0$, and you are supposed to output the first and the last numbers of the whole sequence.

    • 如果数列为5 -10 -20,则输出结果应为5, 5, 5
    • 如果数列为0 -3 0 ,则输出结果应为0 0 0

3 题解

注意int n, sum = -1, leftIndex = 0, rightIndex = n - 1;nrightIndex不能声明在同一行。

#include <iostream>
#include <cstdio>
using namespace std;

const int maxn = 1e4 + 5;
int arr[maxn];

int main(){
    ios::sync_with_stdio(false);
    cin.tie(0);cout.tie(0);

    int n;
    cin >> n;
    int sum = -1, leftIndex = 0, rightIndex = n - 1, temp = 0, tempIndex = 0;
    for(int i = 0;i < n;i++){
        cin >> arr[i];
        temp += arr[i];
        if(temp < 0){
            temp = 0;
            tempIndex = i + 1;
        }else if (sum < temp){
            sum = temp;
            leftIndex = tempIndex;
            rightIndex = i;
        }
    }
    if(sum < 0){
        sum = 0;
    }
    cout << sum << " " << arr[leftIndex] << " " << arr[rightIndex];
    return 0;
}